В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
baandas
baandas
16.04.2023 01:15 •  Информатика

Нужно написать программу в pascal'е. описано так. требуется выделить из предложения четвертое слово (слова разделены пробелом).

Показать ответ
Ответ:
крэкспекс
крэкспекс
16.08.2020 14:18
Var
  s: string;
  i: integer;
  qp: integer;
  word: string;
begin
writeln('Введите предложение разделяя слова пробелами');
readln(s);
qp:=0;
word:='';
for i:=1 to length(s) do begin
  if s[i]=' ' then
    qp:=qp+1
  else begin
     if qp=3 then word:=word+s[i];
  end;
  if qp=4 then
     break;
end;
if word='' then
  writeln('четвёртое слово не присутствует')
else
  writeln('искомое слово - ', word);

end.

{Пример}
На pascal написана соответствующая программа 
искомое слово - соответствующая
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота