В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
Stasya1985
Stasya1985
04.05.2023 07:54 •  Информатика

Нужно написать программу в паскале : с клавиатуры вводится число n. заполнить массив с клавиатуры n значениями и вывести их произведение.

Показать ответ
Ответ:
neznakomka1408
neznakomka1408
03.07.2020 17:13
var
  a: array of byte; //Мы ведь не хотим выйти за пределы даже Int64?
  n, i: byte;          //Больше и не пригодится, массива из 255 значений хватит уж
  l: Int64 := 1;      //Произведение - большая цЫферка

begin
  readln(n);
  System.Array.Resize(a, n);
  for i := 0 to (n - 1) do
  begin
    write('a[', i, '] = ');
    readln(a[i]);
    l *= a[i];
  end;
  writeln(l);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота