В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
МАВ03022004
МАВ03022004
27.03.2020 08:04 •  Информатика

, Нужно написать программу в windows form C#
1задание)Разработать классы для описанных ниже объектов. Включить в класс методы set (…), get (…), show (…). Определить другие методы.
Опишите класс NOTE (фамилия и имя, номер телефона, день рождения с функциями ввода данных в массив, состоящий из n элементов типа NOTE и вывода всех данных и информацию о людях, телефон которых начинается с цифр 232. Если таких нет, то программа должна , выдать соответствующее сообщение на экран.
2задание)Дан двумерный массив. Найти:
а) сумму элементов в строках с k1-й по k2-ю;
б) сумму элементов в столбцах с s1-го по s2-й.

Показать ответ
Ответ:
raha12003
raha12003
08.10.2020 07:12

Python:

import sys#Импортируем библиотеку

#Запрашиваем ввод данных, который записывается в целочисленной переменной

x = int(input("Введите вершину ромба по X: "))

y = int(input("Введите вершину ромба по Y: "))

tx = int(input("Введите целевую точку по X: "))

ty = int(input("Введите целевую точку по Y: "))

if x/2-ty <= tx <= x/2+ty:#Если условие истинно идем дальше

  if y/2-tx <= ty <= y/2+tx:#Если условие истинно идем дальше

     if y-ty >= ty or x-tx >= tx:#Заключительная проверка

        print("Точка входит")#Информируем пользователя о результате в консоли

        sys.exit(0)#Завершаем программу

print("Точка НЕ входит")#Если программа не завершится, т.е условия не выполнятся,

#то сообщим о неудаче.

C++:

#include <iostream>//Необходимо нам для ввода-вывода сообщений в консоль

#include <windows.h>//Необходимо для локализации консоли

using namespace std;/*Это пространственное имя, освобождает нас от обязанности писать std::

для того чтобы получить доступ к функционалу подключенной библиотеки - <iostream>*/

int x, y, tx, ty;//Создаем нужные нам переменные

int main()//Точка входа в программу

{

   //Русский язык в консоли

   SetConsoleCP(1251);

   SetConsoleOutputCP(1251);

   //Выводим в консоль свои требования

   //И

   //Запрашиваем ввод данных, который записывается в целочисленной переменной

   cout << "Введите вершину ромба по X: ";

   cin >> x;

   cout << "Введите вершину ромба по Y: ";

   cin >> y;

   cout << "Введите целевую точку по X: ";

   cin >> tx;

   cout << "Введите целевую точку по Y: ";

   cin >> ty;

   if ((x / 2) - ty <= tx <= (x / 2) + ty)

   {

        //Если условие истинно идем дальше

        if ((y / 2) - tx <= ty <= (y / 2) + tx)//Если условие истинно идем дальше

        {

             if (y - ty >= ty || x - tx >= tx)//Заключительная проверка

             {

                 cout << "Точка входит";//Информируем пользователя о результате в консоли

                 return 0;//Завершаем программу

             }

        }

   }

   cout << "Точка НЕ входит";/*Если программа не завершится, т.е условия не выполнятся,

   то сообщим о неудаче.*/

}

0,0(0 оценок)
Ответ:
Миша7991
Миша7991
26.05.2020 20:12

В настоящее время в мире довольно много различных средств и общения, и колоссальную роль в этом процессе играет Интернет. Ведь общение – это взаимодействия людей друг с другом, а с появлением всемирной паутины это общение вышло за рамки одного дома, города и даже одной страны.

Электронная почта, всевозможные форумы и журналы, организованные в сетевом многочисленные Интернет-журналы и Интернет-газеты и так далее для многих стали не менее важным аспектом повседневности, чем телевизор или телефон.

Бесспорно, много лет существовали и другие средства передачи информации на расстояния (например почта, телефон, телеграф), но те неудобства, с которыми часто сталкивались участники такого общения вынуждают многих перейти в ряды тех, кто уже оценил преимущества нового мира цифровых технологий и Интернета, как наиболее значимого явления в этом мире.

Если обратиться к современной жизни западноевропейских стран и Америке, то можно увидеть, что Интернет уже настолько прочно вошел в быт этих людей, что идеи о создании так называемых «умных домов», управление которыми осуществляется через Интернет, уже не кажутся чем-то недостижимым, а становятся не менее реальными, чем поход в магазин, музей, библиотеку, не выходя из дома и даже не вставая с кресла.

Таким образом, огромная роль Интернета в быту, и в частности, в общении становится с каждым днем все более и более очевидна. Быть может, через несколько десятков лет у каждого человека, не зависимо от его возраста и социального статуса, будет свой компьютер с постоянным подключением к Интернету, электронным почтовым ящиком или даже личной Интернет-страничкой.

Объяснение:

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота