В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
Rona1234
Rona1234
21.12.2020 05:54 •  Информатика

Нужно нарисовать красивую машину грузовоз на qbasic составить программу чтобы программа была сложной и машина грузовик получился красивым​

Показать ответ
Ответ:
DashaTaylor11
DashaTaylor11
19.05.2022 23:22
Прога написанная в codeblocks: #include < iostream> using namespace std; int main() {          setlocale(lc_all,"russian");           int a[20];           int b, c, i, q=0;           for(i=1; i< 21; i++)          {                  cout< < "введите "< < i< < " число: ";                   cin> > a[i];           }          cout< < "введите начальный номер элемента массива: ";     cin> > b;     cout< < "введите конечный номер элемента массива: ";     cin> > c;     for(int j=b; j< c+1; j++)          {                q+=a[j];         }          cout< < "cумма элементов массива с номерами с "< < b< < " по "< < c< < " равна: "< < q; } я надеюсь тебе была нужна прога на с++))
0,0(0 оценок)
Ответ:
yyeyheh
yyeyheh
28.05.2023 00:01
Максимальное число, составленное из утроенного произведения цифр  будет 
9*3*N  -  не  может быть больше 54,  т.е.  
N может быть только 1 или 2.  По условию х>=10  ->  N=2  (N -порядок числа).
Поэтому искать нужно среди чисел от 11 до 54.  Решение - число 15.

var n,m: integer;
begin
  write('n = ');  readln(n);
  if n=2 then
  begin    m:=11;
    repeat
      if (m mod 10)*(m div 10)*3=m then
      begin
        writeln('число:  ',m);
        m:=55;
      end;
      m:=m+1;
    until m>54;
  end
  else  writeln('нет решения');
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота