В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
uikyky
uikyky
24.05.2023 23:14 •  Информатика

Нужно придумать в паскале abc свою с функций abc(x),sqr(x),sqrt(x),round(x),frac(x),int(x),random,random(x).в должно быть хотя бы 2 функции из этих,. )

Показать ответ
Ответ:
ryckovan3
ryckovan3
01.10.2020 11:56
Составить программу, которая заполняет одномерный массив случайными числами из интервала [-50:50] и выводит на экран только те элементы массива, квадратный корень из модуля которых больше пяти

uses crt;
const n=5;
var a:array[1..n] of integer;
i:integer;
begin
randomize;
for i:=1 to n do
begin
a[i]:=random(100)-50;
writeln(a[i]);
end;
writeln;
for i:=1 to n do
if (sqrt(abs(a[i]))>5) then writeln(a[i]);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота