В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
vanо12
vanо12
07.04.2023 06:27 •  Информатика

Нужно составить программу, которая будет отвечать на вопрос является ли число степенью двойки.заранее

Показать ответ
Ответ:
Аня4678
Аня4678
11.08.2020 08:26

#include <stdio.h>

#include <stdlib.h>


int main()

{

int number;

scanf("%d", &number);

number = abs(number);

if(number % 2 != 0)

{

 printf("Не является!");

 return 0;

}

while(number > 2)

{

 number /= 2;

}

if(number == 2)

 printf("Является!");

else printf("Не является!");

}


Нужно составить программу, которая будет отвечать на вопрос является ли число степенью двойки.заране
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота