Нужно составить программу, которая по введенной k-й секунде суток определяет, сколько целых часов h и целых минут с начала суток.
program gat;
var k,h,m:integer;
begin
write ('Введите количество секунд ');
readln ('k');
h:=k div 3600;
m:=(k-h)*3600 div 60;
writeln ('It is ','h',' hours ','m',' minutes');
end.
паскаль ide выдает ошибки: error in type definition, variable identifier expected, variable "k" does not seem to be initialized, identifier not found "m".
что нужно исправить?
А)
program c1;
var
a, b: integer;
c: real;
begin
a := 2;
b := 3;
c := a + 1 / 3;
write(c);
end.
Б)
program c2;
var
a, b: integer;
c: real;
begin
a := 2;
b := 3;
c := a + 4 / 2 * 3 + 6;
write(c);
end.
В)
program c3;
var
a, b: integer;
c: real;
begin
a := 2;
b := 3;
c := a + 4 / 2 * 3;
write(c);
end.
Объяснение:
А)
program c1; // Название программы
var // Раздел для описания переменных
a, b: integer; // Объявление целочисленных переменных
c: real; // Объявление вещественной переменной
begin // Начало программы
a := 2; // a = 2
b := 3; // b = 3
c := a + 1 / 3; // c = a + 1 ÷ 3
write(c); // Выводим ответ
end. // Конец программы
Б)
program c2; // Название программы
var // Раздел для описания переменных
a, b: integer; // Объявление целочисленных переменных
c: real; // Объявление вещественной переменной
begin // Начало программы
a := 2; // a = 2
b := 3; // b = 3
c := a + 4 / 2 * 3 + 6; // c = a + 4 ÷ 2 × 3 + 6
write(c); // Выводим ответ
end. // Конец программы
В)
program c3; // Название программы
var // Раздел для описания переменных
a, b: integer; // Объявление целочисленных переменных
c: real; // Объявление вещественной переменной
begin // Начало программы
a := 2; // a = 2
b := 3; // b = 3
c := a + 4 / 2 * 3; // c = a + 4 ÷ 2 × 3
write(c); // Выводим ответ
end. // Конец программы
Системное ПО обеспечивает работу компьютера (загрузка ядра, драйверов, проверка портов, синхронизацию устройств и протоколов передачи данных, чтение, передачу данных, осуществляют слежение за устройствами ввода-вывода и реагируют на команды с них и т. д.) . Прикладные программы используют системное ПО, но выполняют действия и функции не влияющие на систему, а имеющие прикладное значение (просмотр и обработка видео, математические вычисления, запись на внешние носители, игры...).
Объяснение:
незнаю проавельный это ответ или нет