В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
ученик1523
ученик1523
04.06.2020 11:28 •  Информатика

очень Составить программу на языке Паскаль и записать в тетрадь по алгоритму

Алгоритм решения линейного уравнения ах=в, где а и в произвольные вещественные числа

алг линейноеуравнение

арг а,в

рез х,у

нач

если а≠0

то у:= «есть решение» х:=в/а

иначе если в=0 то у:= «х-любое число» иначе у:= «решений нет»

всё

всё

кон

Показать ответ
Ответ:
kamshatsabyr
kamshatsabyr
30.08.2020 08:19

var

a, b, x,y:Real;

begin

ReadLn(a, b);

if (a<0) or (a>0) then

begin

y:= b/a;

WriteLn(y);

end

else if (b<0) or (b>0) then

WriteLn('Решений нет')

else

WriteLn('x-любое число');

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота