Операторы ввода и вывода 3-- Карточка No 4 Составьте программу, которая с тремя произвольными числами a, bис, введенными с клавиатуры, производит вычисления по следующим формулам: 15,5 d= с- За + Ь a - b 4 as + b2 с2 а - С a-b2 + 2 - 2 (а - в) ) - + 5,5; 4 - 3а2 .- 3с e f=d+ Is - a+ 3c — Б?; b2 17,5 d-b2 +a 21с. 1 = d-b Отладьте программу на следующем примере: b d f 3 2 2 27.7454 23.9 84.7936 h e а C --40.9543
var
s: string[6];
n: integer;
begin
s := 'отлично';
n := length(s);
writeln(length('отлично'));
writeln(n);
end.
Изначально выставлен тип string[6], значит если присвоить строку больше, то ее обрежет по 6 символов, вот и весь прикол
ответ 6
2) рисунок
3)var
s, s1: string;
n: integer;
begin
s := 'информатика';
s1 := copy(s, 3, 5);
n := pos(s, s1);
writeln('s=', s);
writeln('s1=', s1);
writeln('n=', n);
end.
Вывод
s=информатика
s1=форма
n=0
Все верно, в s1 не содержится s, а наоборот
Ақпарат көзі – адам, ұжым және деректер. [1]. Деректерді жинау кезінде журналист ақпараттарды түрлі көздерден алады. Кейіпкер журналиске өзі немесе жолдастары жайында мәлімет беруге міндетті емес. Олардың экран алдында ашылулары үшін оған себеп, дәлел, сылтау керек. Егер олар жауап беруден бас тартқан жағдайда, қысым жасаудың қажеттігі жоқ. Мүмкін, сіз таңдаған кейіпкер туралы көпшілік пікірі басқаша болуы немесе сіз істейтін редакция жайындағы көзқарастың тым теріс бағытта да болуы мүмкін екенін ескеріңіз. Ақпарат алудың ұжымдық түріне формалды және формалды емес қатынас, жиналыс, мәжіліс, конференция, дөңгелек үстел, ба з конференциясы т.б. жатады. Мұның бағалылығы: онда шыншыл көзқарастардың үстемдік алып, журналистің проблема, оқиға туралы дәл, айқын ой түйіндеуіне жол ашатындығы. Ал айда, кей сәттерде шындықтан алып жататын деректердің де хабарланатынын ескеру керек. Журналист көпшілігінде деректерге жүгінеді. Деректермен танысуға автордың рұқсатымен кірісу қажет. Автордың рұқсаты бар екенін ескеру де қажеттілік және онда дәлдіктің кейде сәйкессіздіктің болатынын да аудиторияға қоса хабарлау шарттылық.
Объяснение: