В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
KotyaSuper11
KotyaSuper11
29.05.2020 01:44 •  Информатика

Определите к каким видам программ относятся следующие программы: Windows NT
Photo Shop
Fortan
Norton Antivirus

Показать ответ
Ответ:
милана200229
милана200229
28.01.2021 09:33

1.

program z1;

var a:array [1..10] of integer;

i,k:integer;

begin

write ('Введите элементы массива через пробел и нажмите Enter ');

for i:=1 to 10 do read (a[i]);

write ('Массив: ');

for i:=1 to 10 do write (a[i],'  ');

writeln;

write ('Номера элементов больше 5: ');

for i:=1 to 10 do if a[i] > 5 then

begin

write (i,'  ');

k:=k+1

end;

writeln;

writeln ('Элементов больше 5: ',k)

end.

2.

program z2;

var s:string;

begin

readln (s);

while pos('о',s)<>0 do delete(s,pos('о',s),1);

writeln(s)

end.

Объяснение:

Смотри картинки

2. Программа удаляет только строчные русские о


НУЖНА ЗАДАЧА: Составить программу на Паскале для обработки одномерного массива из 10 элементов. Знач
НУЖНА ЗАДАЧА: Составить программу на Паскале для обработки одномерного массива из 10 элементов. Знач
0,0(0 оценок)
Ответ:
Фарук11
Фарук11
28.01.2021 09:33
1.                                                        

program raf105;

var a,sum:integer;

begin

writeln('Вводите числа по очереди');

writeln('Чтобы закончить введите 0');

repeat

 readln(a);

 sum+= a;

until a=0;

writeln('Сумма: ',sum);

end.

2.                                                        

program raf105;

var

s:string;

i,k,j:integer;

poli:boolean;

begin

poli:= true;

write('Введите слово: ');

readln(s);

s:= lowercase(s);

k:= length(s) div 2;

j:= k*2+1;

if (length(s) mod 2)<>0

 then j+= 1;

for i:=1 to k do

begin

 j-=1;

 if poli

   then poli:= s[i] = s[j];

end;

if poli

 then writeln('Слово - палиндром')

 else writeln('Слово - не палиндром');

end.

 

3.                                                        

program raf105;

var a:array[1..10] of integer;

x,i:integer;

begin

writeln('Вводите 10 чисел по очереди');

for i:=1 to 10 do

 readln(a[i]);

write('Введите искомое число: ');

readln(x);

write('Индексы совпадающих элементов: ');

for i:=1 to 10 do

 if a[i] = x

   then write(i,' ');

end.

4.                                                        

program raf105;

var a:integer;

begin

write('Введите номер дня недели: ');

readln(a);

case a of

 1: writeln('Это Понедельник');

 2: writeln('Это Вторник');

 3: writeln('Это Среда');

 4: writeln('Это Четверг');

 5: writeln('Это Пятница');

 6: writeln('Это Суббота');

 7: writeln('Это Воскресенье');

end;

end.

5.                                                        

program raf105;

var a:array[1..100] of integer;

i,o,x: integer;

begin

writeln('Вводите числа по очереди');

writeln('Чтобы закончить введите 0');

repeat

 o+= 1;

 readln(a[o]);

until a[o]=0;

o-= 1;

writeln('Введённые числа в обратном порядке:');

for i:=o downto 1 do

 writeln(a[i]);

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота