От прямоугольника каждый раз отрезается квадрат максимальной площадью. составьте программу которая находит число таких квадратов. программа получает на вход два целых положительных числа a и b (длины сторон прямоугольника). программа должна вывести число получившихся квадратов.
вход
5
8
выход
5
напишите программу на языке python
Компьютеры, телефоны, мониторы. Без этой техники уже трудно представить жизнь. Исследования учёных влияния компьютерных излучений на здоровье привели в волнение офтальмологов, косметологов, дерматологов и ортопедов. Доктора подтверждают снижение остроты зрения, увеличение веса, ускорение старения кожи лица
Исследования учёных
Западными учёными несколько лет проводились наблюдения изменения кожи лица у двух групп женщин. Одна группа работала за компьютером весь день, другая – время от времени. Отмечено, что у первой группы признаки старения и дряхлости лица появились раньше.
Кожа потеряла эластичность, щёки обвисли, лицо потеряло контур, заметных морщин стало больше, некоторые дамы обзавелись вторым подбородком.
Причина неприятностей – в электростатическом поле, которое создаётся вокруг экрана и сушит воздух. Ещё одна причина – микрочастицы, оседающие и загрязняющие лицо. Глаза краснеют, появляется раздражение и воспаление.

Последствия:
· иссушение кожных покровов;
· расширение и забитость пор;
· излишняя жирность кожи;
· глаза окружены морщинистой сеточкой;
· сухие веки;
· расширенные сосуды на щеках;
· появление второго подбородка;
· мимические морщины.
Исследователями предлагаются профилактические меры, предотвращающие влияние вредных излучений
C++
#include <iostream>#include <vector>int main () { int a, b, c; std::cin >> a >> b >> c; std::vector list {a, b, c}; bool is_it_correct = std::find_if(list.begin(), list.end(), [](auto el){ return el > 0; }) != list.end() && std::find_if(list.begin(), list.end(), [](auto el){ return el < 0; }) != list.end(); if (is_it_correct) std::cout << "YES" << std::endl; else std::cout << "NO" << std::endl;}