В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
DenisKazansev
DenisKazansev
23.10.2021 05:21 •  Информатика

Pascal Дан массив, содержащий 20 положительных целых чисел, не превышающих 30 000. Необходимо найти в этом массиве количество элементов, которые кратны 3, а их десятичная запись заканчивается цифрой 1, и заменить каждый из таких элементов на это количество. Напишите программу для решения этой задачи. В качестве результата программа должна вывести изменённый массив, по одному элементу в строке. Например, для исходного массива из 5 элементов

15 71 21 111 41

программа должна вывести (по одному числу в строке) числа

15 71 2 2 41.

Показать ответ
Ответ:
vidadisaf
vidadisaf
28.02.2020 10:16

Решение на c++:

#include <iostream>

#include <ctime>

int main()

{

   int N, i, a, b, k1 = 0, k2 = 0, s1 = 0, s2 = 0;

   int A[10000];

   std::cin >> a >> b >> N;

   srand(time(0));

   for (i = 0; i < N; i++)

   {

       A[i] = rand()%(b-a+1)+a;

       if (A[i] < 50)

       {

           k1++;

           s1 += A[i];

       }

       else

       {

           k2++;

           s2 += A[i];

       }

       std::cout << A[i] << " ";

   }

   std::cout << std::endl << ((k1 == 0) ? 0 : (s1*1./k1)) << " ";

   std::cout << ((k2 == 0) ? 0 : (s2 * 1. / k2)) << " ";

   return 0;

}

0,0(0 оценок)
Ответ:
Tringt
Tringt
28.02.2020 10:16
#include <ctime>
#include <iostream>

using namespace std;

int main(){
srand(time(NULL));
int n;
cout << "Vvedite N << endl;
cin >> n;
int arr[n];
int a,b;
cout << "Vvedite diapozon A-B cherez probel" << endl;
cin >> a >> b;
for (int i=0; i<n; i++) a[i]=rand()%b+a;
int s50 = 0;
int ss50 = 0;
int s = 0;
int ss = 0;
for (int i=0; i<n; i++) {
if (a[i]<50) {
s50+=a[i];
ss50++;
} else {
s+=a[i];
ss++;
}
}
cout << "Srednee arifmeticheskoe chisel menshe 50 ravno " << s50/ss50 << endl;
cout << "Srednee arifmeticheskoe chisel ostalnix elementov ravno " << s/ss;
return 0;
}
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота