Войти
Регистрация
Спроси ai-bota
В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
Показать больше
Показать меньше
ishnlv
20.02.2023 11:09 •
Информатика
Pascal составить программу поиска трех значных чисел, сумма цифр которого равна n
Показать ответ
Ответ:
Griezman7
08.09.2020 19:57
Var
i, n, s, k: integer;
begin
readln(n);
for i := 100 to 999 do
begin
s := 0; k := i;
while k > 0 do
begin
s := s + k mod 10;
k := k div 10;
end;
if s = n then
writeln(i);
end;
end.
0,0
(0 оценок)
Популярные вопросы: Информатика
margo1236
10.02.2023 23:33
7) В ячейку В1 записали формулу =F2+D2*E$1. Затем ячейку В1 скопировали во все ячейки диапазона А1:06. Какое наибольшее числовое значение появится в ячейках этого диапазона?...
Stepan0305
20.02.2020 10:00
PYTHON Поле шахматной доски определяется парой натуральных чисел, каждое из которых не превосходит 8. По введенным координатам двух полей (kl) и (mn) выясните, угрожает ли ферзь, находящийся...
миха395
06.12.2022 10:55
Салгоритма rle закодируйте сообщение ....
saraavetisyan2
22.08.2020 20:54
Выпишите все десятичные числа,не превосходящие 80 ,запись которых в четырнадцатиричной системе счисления оканчивается цифрой 6....
lolshowsasdasfd
16.02.2021 10:35
ПИТОН. Задания по теме «Ветвление» Задача № 1 Даны три целых числа. Выбрать из них те, которые принадлежат интервалу [1,3]. Задача № 2 Написать программу вычисления стоимости покупки...
Topxic
07.12.2020 22:12
Информатика В тетради решить следующие задания: 1. Определите значение переменной a после исполнения данного алгоритма. a := 3 b := 5 + 2*a a := b*а -3 2.Переменная А=1, переменная...
fynju
05.02.2020 16:41
Решите контрольную «Коммуникационные технологии»...
Nikita45Russia
28.05.2020 15:57
Назовите как можно больше характеристик объекта пара ботинок...
arinasmail1
13.08.2022 02:17
Напишите единицы измерения информации между 0,25 кбайт и 0,125 пбайт...
LaGGe
27.02.2023 09:54
, МНЕ НУЖНО СДАТЬ ДО ОБЕДА ...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
Спроси ai-бота
i, n, s, k: integer;
begin
readln(n);
for i := 100 to 999 do
begin
s := 0; k := i;
while k > 0 do
begin
s := s + k mod 10;
k := k div 10;
end;
if s = n then
writeln(i);
end;
end.