В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
сhevapchichi0
сhevapchichi0
18.11.2021 06:42 •  Информатика

Pascal В списке участников международной конференции указывается их национальность и возраст. Список упорядочен по возрасту участников. Определить самого молодого и самого пожилого русского участника. Нужно написать программу.

Показать ответ
Ответ:
Роли5
Роли5
15.10.2020 13:18

Держи ;)

Var year,s,y,o:integer; old,young,name,nation:string;

Begin

s:=0;

o:=0;

y:=200;

While (s=0) do

Begin

Write('Введите имя и фамилию участника. Если список окончен, напишите "конец": ');

Readln(name);

If (name='конец') then break;

Write('Введите национальность участника: ');

Readln(nation);

Write('Введите возраст участника: ');

Readln(year);

If (year > o) and (nation='русский') then

Begin

o:=year;

old:=name;

end;

If (year < y) and (nation='русский') then

Begin

y:=year;

young:=name;

end;

end;

Write('Самый молодой русский участник - ',young,', самый старый русский участник - ',old);

End.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота