В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
korsukova61oye48j
korsukova61oye48j
31.08.2022 05:10 •  Информатика

Pascal - Задача решить. Составить программу, вычисляющую стоимость покупки с учетом скидки: если покупка превышает 1500 р., то начисляется скидка 3%, если превышает 2000, то начисляется скидка 5%. Выше 4000 - скадка 7%. На вход - стоимость покупки, выход - сколько нужно оплатить.

Показать ответ
Ответ:
dhdb1
dhdb1
15.02.2021 17:36

var x: real;

begin

  writeln('введите цену товара');

 read(x);

 if x>4000 then x:=x-x*0.07 else

    if x>2000 then x:=x-x*0.05 else

      if x>1500 then x:=x-x*0.03;

    write(x)

     

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота