В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
olya2005i
olya2005i
12.02.2021 05:55 •  Информатика

Pascalabc 1. напишите программу, которая работает с двумя целыми числами, введёнными с клавиатуры. программа выводит все чётные числа, расположенные в интервале между двумя введёнными числами. например, пользователь вводит числа 10 и 20, программа выводит «12 14 16 18», если -8 и -3, то «-6 –4». если пользователь вводит, например, числа 6 и 8, программа ничего не выводит. точно так же программа ничего не выводит, если введённые числа равны, или второе указанное число меньше первого.

Показать ответ
Ответ:
dossovatomiris030
dossovatomiris030
02.10.2020 05:35
Var  
 a,b,i : integer;    
 begin 
  readln (a,b); 
   for i := (a+1) to (b-1) do 
   if i mod 2 = 0 then 
     writeln (i); 
end.

вроде работает pascalABC.Net
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота