Войти
Регистрация
Спроси ai-bota
В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
Показать больше
Показать меньше
Maryan2609
22.05.2020 23:09 •
Информатика
Pascalabc составьте программу для вычисления значения силы тока i на участке, состоящем из двух параллельно соединенных сопротивлением r1 и r2, если напряжение на концах этого участка равно u.
Показать ответ
Ответ:
Or003
02.10.2020 16:25
//Общее сопротивление сети:
// 1/R = 1/r1 + 1/r2
// 1/R = (r2+r1)/(r2*r1)
// R = r2*r1 / (r2 + r1)
//Закон Ома для участка цепи:
// I = U/R
var
r1,r2,u : integer;
R,I : real;
begin
writeln ('Введите значения сопротивления (r1 r2)');
readln (r1,r2);
writeln ('Укажите напряжение на концах цепи (u)');
readln (u);
R := r2*r1 / (r2 + r1);
I := U/R;
//Фактически можно не использовать переменную R
//А вставить выражение сразу
// I := U/( r2*r1 / (r2 + r1) );
writeln ('Сила тока на участке = ',I);
end.
0,0
(0 оценок)
Популярные вопросы: Информатика
евака2
24.05.2022 21:45
Сколько бит и байт в двух словах компьютерная сеть ?...
Clem404
30.05.2021 06:59
Перевел ите число 516 из лесятичной системы счисления в двоичную систему счисления . сколько единиц содержит полученное число ? в ответе укажите одно число - количество...
sevara221
25.01.2021 00:17
Построить таблицу истинности для выражения: a& неa v b& неb...
renata82
19.08.2020 04:17
Скорость передачи данных через ADSL-соединение равна 256000 бит/c. Передача файла через данное соединение заняла 37 секунд. Определи размер файла в Кбайт...
YoY88ghtulop
09.01.2021 09:51
Написать на алгоритмическом языкеВот и подошел к концу первый семестр в университете. Андроид Вася успешно сдал все экзамены и теперь хочет узнать, будет ли у него...
Nikikiki303
20.02.2023 00:05
3%%. Найди математическое выражение, записи выражения на языке Python. .1) (p+k+ 4) / (4 +t) — 4 *р*k / (3 – 2*b) 5) (х + 3-у ++ 3) = (х іth 3- 2)2) abs (4 + х)...
svistmi20061
07.01.2020 10:41
Чи доцільно обирати банк, опираючись лише на рекламну ін-формацію про нього? Яка інформація важлива вкладникові під часвибору банку?...
vipyanalukyan
14.11.2021 03:58
Проволоку сопротивлением 16 Ом разрезали на 8 равных частей, которые после этого соединили между собой параллельно . Каким будет эквивалентное сопротивление этого...
milenakag2008
25.03.2021 04:08
Заполните таблицу.Описание как того шагаПрограмма на име Scratchданни в моно)си н е ранее 100...
Студентка16епта
18.09.2020 07:34
Хімічний символ двох атомів Оксигену...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
Спроси ai-бота
// 1/R = 1/r1 + 1/r2
// 1/R = (r2+r1)/(r2*r1)
// R = r2*r1 / (r2 + r1)
//Закон Ома для участка цепи:
// I = U/R
var
r1,r2,u : integer;
R,I : real;
begin
writeln ('Введите значения сопротивления (r1 r2)');
readln (r1,r2);
writeln ('Укажите напряжение на концах цепи (u)');
readln (u);
R := r2*r1 / (r2 + r1);
I := U/R;
//Фактически можно не использовать переменную R
//А вставить выражение сразу
// I := U/( r2*r1 / (r2 + r1) );
writeln ('Сила тока на участке = ',I);
end.