В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
samiragubai
samiragubai
23.10.2021 06:04 •  Информатика

Pascalabs составить программу которая определяет 1) является ли число положительным или отрицательным. 2) считает числа отрицательные и положительные. 3) считает сумму отрицательных и положительных

Показать ответ
Ответ:
emilyblack80
emilyblack80
07.10.2020 23:53
Var a,i,k1,k2,s1,s2:integer;
begin
for i:=1 to 3 do begin
 readln(a);
 if a>0 then begin
  writeln('Число ',a,' положительное');
  k1:=k1+1; s1:=s1+a;
 end else if a<0 then begin
  writeln('Число ',a,' отрицательное');
  k2:=k2+1; s2:=s2+a;
 end;
 end;
writeln('Количество положительных = ',k1,', их сумма = ',s1);
writeln('Количество отрицательных = ',k2,', их сумма = ',s2);
end.

Пример:
15
Число 15 положительное
-74
Число -74 отрицательное
28
Число 28 положительное
Количество положительных = 2, их сумма = 43
Количество отрицательных = 1, их сумма = -74
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота