В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
obilan228
obilan228
26.01.2022 16:17 •  Информатика

ПАСКАЛЬ Дан одномерный массив A[10]. Элементы массива – это случайные числа большие 0.
Написать программу, которая будет находить произведение элементов массива,
лежащих в интервале [20, 70].

Показать ответ
Ответ:
plotnikdias
plotnikdias
23.08.2020 20:14

var i,s: integer;

begin

s:=1;

randomize();

for i:=1 to 10 do

 begin

 A[i]:=random(100);

 write(A[i],' ');

 if (A[i]>=20) and (A[i]<=70) then

 s:=s*A[i];

 end;

writeln();

writeln('Произведение элементов массива: ',s);

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота