Войти
Регистрация
Спроси ai-bota
В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
Показать больше
Показать меньше
muxtarova2007
27.05.2022 07:57 •
Информатика
Паскаль! функции! найдите среднее арифметическое квадратов всех целых чисел от 1 до k (k вводится с клавиатуры )
Показать ответ
Ответ:
Roman4ik1207
22.09.2020 23:49
Var k:integer;
function sr(n:integer):real;
var i,s:integer;
begin
s:=0;
for i:=1 to n do s:=s+i*i;
sr:=s/n;
end;
begin
write('k='); readln(k);
writeln('Среднее арифметическое = ', sr(k));
end.
Пример:
k=5
Среднее арифметическое = 11
0,0
(0 оценок)
Популярные вопросы: Информатика
SHEVENIST
04.02.2022 14:09
Скорость передачи данных через adsl-соединение равна 32000 байт/с через данное соединение передает файл размером 10000 кбит. определите время передачи файла секундах....
dinaragappar
04.02.2022 14:09
Сколько значащих нулей в двоичной записи восьмеричного числа 77158?...
Vergoon
04.02.2022 14:09
Дан массив t (m, n). отсортировать столбцы по убыванию их средних значений...
Dubrov5ky
04.02.2022 14:09
Фрагмент программы определяет является ли числовая последовательность в массиве строго возрастающей. подскажите, , что в скобках после if? //а - целочисленный массив с индексами...
anastasiya2056
04.09.2022 13:37
Установите взаимно-однозначное соответствие. КОНТРОША...
ппапаапа
26.11.2020 10:32
17 (24). ДІЇ З ГРАФІЧНИМИ ОБ ЄКТАМИТЕКСТОВОГО ДОКУМЕНТА1.Відкрийте вкладку Формат і опишіть, які дії можна виконати з різними групами інструментів.2. До тексту потрібно додати...
nastyagrigorov
09.04.2022 21:46
написать программу в ABCPascal дано трехзначное число, найти и вывести его вторую цифру...
snezhanakosola
10.01.2023 16:53
Перечислите устройства хранения информации. Какая их характеристика является основной? В каких единицах она измеряется?...
Frog12321nik
03.09.2021 10:39
Інформатика завданням Python...
DoVInterER
16.09.2021 01:46
Exel. Нужно в ячейке B5 получить 8 951,68 USD с функций и имеющихся данных, что бы при их изменении, число в ячейке B5 тоже изменялось...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
Спроси ai-бота
function sr(n:integer):real;
var i,s:integer;
begin
s:=0;
for i:=1 to n do s:=s+i*i;
sr:=s/n;
end;
begin
write('k='); readln(k);
writeln('Среднее арифметическое = ', sr(k));
end.
Пример:
k=5
Среднее арифметическое = 11