В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
mixajlovdenisk
mixajlovdenisk
04.01.2023 10:34 •  Информатика

Паскаль Написать программу поиска стоимости телефонного разговора в будний день (пн-пт), со скидкой в 15% в субботу и 25% - в воскресенье. CASE работает по вводу номера дня недели (1-7).

Показать ответ
Ответ:
alinasun230503
alinasun230503
17.09.2022 10:27

Интернет всемирная глобальная компьютерная сеть.

World Wide Web - Всемирная паутина:сетевой сервис, поддерживающий гипертекстовое пространство Интернета.

Web -страница - отдельный документ W W W.

Web - сервер - компьютер в сети Интернет, хранящий Web-страницы и соответствующее программное обеспечение для работы с ним.

Web - сайт- совокупность тематически связанных Web - страниц.

Гипермедия-система гиперсвязей между мультимедиа документами.

Web - браузер-клиент-программа для работы пользователя с W W W.

Киберпространство совокупность мировых систем телекоммуникаций и циркулирующей в них информации

0,0(0 оценок)
Ответ:
bulavskaaana
bulavskaaana
09.01.2020 07:34

using System;

internal class Program {

   private static void Main() {

       Console.WriteLine("Введите минимум для счетчика");

       var min = int.Parse(Console.ReadLine() ?? throw new ());

       Console.WriteLine("Введите максимум для счетчика");

       var max = int.Parse(Console.ReadLine() ?? throw new ());

       Console.WriteLine("Введите значение для счетчика");

       var v = int.Parse(Console.ReadLine() ?? throw new ());

       var counter = new Counter(max, min, v);

       Console.WriteLine("Введите + для увеличение и - для уменьшения, иное для выхода");

       do {

           var c = Console.ReadKey();

           if (c.KeyChar == '+') counter.Increase();

           else if (c.KeyChar == '-') counter.Decrease();

           else break;

           Console.WriteLine($" => {counter.Value}");

       } while (true);

       Console.ReadKey();

   }

}

public class Counter {

   public readonly int Maximum;

   public readonly int Minimum;

   public int Value { private set; get; }

   public Counter(int maximum, int minimum, int counter) {

       this.Maximum = maximum;

       this.Minimum = minimum;

       counter = Math.Min(this.Maximum, counter);

       counter = Math.Max(this.Minimum, counter);

       this.Value = counter;

   }

   private Counter() {

       this.Maximum = 10;

       this.Minimum = 0;

       this.Value = 5;

   }

   public void Increase() {

       var value = this.Value + 1;

       if (value > this.Maximum || value < this.Minimum)

           return;

       this.Value++;

   }

   public void Decrease() {

       var value = this.Value - 1;

       if (value > this.Maximum || value < this.Minimum)

           return;

       this.Value--;

   }

}

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота