В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
cangelina2025
cangelina2025
01.12.2020 14:58 •  Информатика

Паскаль пусть вводится последовательность вещественных чисел, оканчивающаяся нулем и состоящая более чем из одного ненулевого элемента. определите наибольшее число последовательности.

Показать ответ
Ответ:
Dillzy
Dillzy
21.07.2020 23:58
Попробуй так:

uses Crt;
var a, Max: real;
    i: integer;
begin
ClrScr;
i:=0;
Repeat
  i:=i+1;
  Write ('a',i,'='); ReadLn (a);
  if a<>0 then
      begin
        if a>Max then Max:=a;
      end;
  until a=0;
WriteLn;
WriteLn(' Max = ', Max:6:4);
ReadLn;
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота