Перед вами фрагмент программы. a := ?; b := ?; if (a < 4) or (b > 10) then write(1) else write(2); Для каких начальных значений переменных a и b программа напечатает число 1? Выберите все подходящие варианты.
a := 5; b := 100; a := 4, b := 10; a := 1; b := 11; a := 4; b := 20; a := 3; b := 1;
Какой минимальный объём памяти (в Кбайт) нужно зарезервировать, чтобы можно было сохранить любое растровое изображение размером 320×640 пикселей при условии, что в изображении могут использоваться 256 различных цветов? В ответе запишите только целое число, единицу измерения писать не нужно.
Решение.
Заметим, что 256 = 28, то есть для хранения цвета одного пиксела изображения нужно использовать 8 бит = 1 байт. Значит, для хранения изображения размером 320×640 пикселей нужно использовать:
uses graphABC;
Begin
Setbrushstyle(bsClear);
SetPenWidth(13);
SetPenColor(clBlue);
Circle (140,200,100);
SetPenColor(clBlack);
Circle (320,200,100);
SetPenColor(clRed);
Circle (500,200,100);
SetPenColor(clYellow);
Circle (240,315,100);
SetPenColor(clGreen);
Circle (420,315,100);
SetPenColor(clBlue);
Arc(140,200,100,-17,90);
SetPenColor(clBlack);
Arc(320,200,100,180,200);
SetPenColor(clBlack);
Arc(320,200,100,-15,90);
SetPenColor(clRed);
Arc(500,200,100,180,270);
SetPenColor(clYellow);
Arc (240,315,100,0,45)
end.
Объяснение:
картинка
Какой минимальный объём памяти (в Кбайт) нужно зарезервировать, чтобы можно было сохранить любое растровое изображение размером 320×640 пикселей при условии, что в изображении могут использоваться 256 различных цветов? В ответе запишите только целое число, единицу измерения писать не нужно.
Решение.
Заметим, что 256 = 28, то есть для хранения цвета одного пиксела изображения нужно использовать 8 бит = 1 байт. Значит, для хранения изображения размером 320×640 пикселей нужно использовать:
1 · 320 · 640 = 10 · 25 · 10 · 26 = 100 · 211 байт = 200 Кбайт.
ответ: 200.