перевести с с++/паскаля на phyton или решить задачу!! задача:
Напишите программу , которая в последовательности натуральных чисел определяет наибольшее двузначное число, меньше 80. программа получает на вход натуральные числа , количество введенных чисел неизвесно, последовательномть чисел заканчивается числом 0. В последовательности всегда имеется двузнпчное число, меньше 80.
С++
#include
void main()
{
int i, max = 10;
while(std::cin >> i)
{
if(i == 0) break;
if(i > max && i < 80) max = i;
}
std::cout << i << endl;
}
паскаль:
begin
var a := ReadSeqIntegerWhile('Введите числа:',x -> x = 0).ToArray;
var check := 0;
foreach x: integer in a do begin
if (x < 80) and (x > 9) then
check +=1;
if (a.Count > 1000) and (x > 3000) then
exit;
end;
if check = 0 then
exit;
a.Where(x -> (x < 80) and (x > 9)).Max.Print
end.
Відповідь:
int main() {
int i, max = -1;
while(std::cin >>i)
{if(i==0) break;
else if(i > max && i < 80) max = i;
}
std::cout << max << std::endl;
return 0;
}