В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
daryastasevich1
daryastasevich1
31.07.2020 17:18 •  Информатика

ПИСАТЬ ОБЯЗАТЕЛЬНО НА ЯЗЫКЕ "Python"

Задача 1

В кассе продаются проездные билеты на месяц. За с

клавиатуры стоимость проездного билета для школьника и студента, а также

количество билетов каждого вида на начало продажи и количество проездных

каждого вида на момент окончания торговли. Вывести, какую сумму за это время

заработал магазин.

Задача 2

За с клавиатуры стороны параллелограмма и высоту,

опущенную к одной из сторон. Написать программу, вычисляющую длину высоты,

опущенной к другой стороне.

Задача 3

Первое практическое занятие в университете начинается в 9-40. Все

занятия длятся 1 час 30 минут, перерыв составляет 10 минут. Далее идёт

чередование: следующая пара посвящена лекции, потом снова будет

практическое занятие и т. д.. Написать программу, которая получает с клавиатуры

номер практического занятия и выводит время его конца.

ПИСАТЬ ОБЯЗАТЕЛЬНО НА ЯЗЫКЕ "Python"

Показать ответ
Ответ:
Cancanich
Cancanich
26.09.2021 16:47

program xxx;
var i, j, k, n, p, s : integer;
    a : array [1..20] of integer;
begin
  write ('введите количество инверсий -');
  readln(k);
  write ('введите количество ламп -');
  readln(n);
  for i:=1 to n do
    a[i]:=0;
  for i:=1 to k do
    begin
      write ('введите инверсию P-');
      readln(p);
      j:=p;
      while j<=n do
        begin
          if a[j]=0 then a[j]:=1 else a[j]:=0;
          j:=j+p
        end
    end;
  s:=0;
  for i:=1 to n do
    if a[i]=1 then s:=s+1;
  write ('Ламп горит -', s);
  readln
end.

0,0(0 оценок)
Ответ:
veronikaandruseiko
veronikaandruseiko
17.05.2020 17:20
Const
n=5;m=6;
var
a:array[1..n,1..m]of integer;
b:array[1..m]of longint;
k,i,j:integer;
p:longint;
begin
   for i:=1 to n do
      begin
         writeln;    
            for j:=1 to m do
                 begin
                    a[i,j]:=random(20)-10;
                     write(a[i,j]:4);
                 end;
      end;
writeln;

for j:=1 to m do
  begin
p:=1;
     for i:=1 to n do
          if (a[i,j]mod 2=0)and(a[i,j]>0) then
             p:=p*a[i,j];
if p<>1 then
  begin
     k:=k+1;
     b[k]:=p;
  end;
end;
for i:=1 to k do
   write(b[i]:8);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота