ПИТОН
Напишите программу, которая заполняет массив из 10 элементов случайными числами в диапазоне [100,500] и выводит его на экран. После этого на экран выводятся суммы цифр всех чисел, записанных в массив.Пример:Массив: 162 425 340 128 278 195 326 414 312 177 Суммы цифр: 9 11 7 11 17 15 11 9 6 15
//1)
var
A: array [1..8] of integer;
i: byte;
sum: integer;
Arifm: real;
begin
writeln('Заполнение массива.');
sum := 0;
for i := 1 to 8 do
begin
write('A[',i,'] = ');
readln(A[i]);
sum := sum + A[i];
end;
Arifm := sum/8;
writeln('Среднее арифметическое всех элементов = ', Arifm);
writeln;
writeln('Элементы меньше среднего арифметического.');
for i := 1 to 8 do
if A[i] < Arifm then
write(A[i]:4);
writeln; readln;
end.
//2)
var
A: array [1..8] of integer;
i: byte;
sum: integer;
Arifm: real;
begin
writeln('Заполнение массива.');
sum := 0;
for i := 1 to 8 do
begin
write('A[',i,'] = ');
readln(A[i]);
if i mod 2 <> 0 then
sum := sum + A[i];
end;
Arifm := sum/4;
writeln('Среднее арифметическое элементов с нечетн. индексами = ', Arifm);
readln;
end.
код:
using System;namespace ConsoleApp95{ class Program { static void Main(string[] args) { int N, M,S = 0 ,SB = 0 ,SA = 0 ; N = Convert.ToInt32(Console.ReadLine()); M = Convert.ToInt32(Console.ReadLine()); for ( int i = N+1; i < M; i++) { if ( i % 2 == 0 ) { S += i; SA += i; } else { SB += i; } } Console.WriteLine(S + " " + SA + " " + SB); Console.ReadKey(); } }}