В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
2329992ляля
2329992ляля
28.10.2020 20:03 •  Информатика

Плесс. на языке паскаля. напишите программу,которая в последовательности натуральных чисел определяет минимальное,оканчивающееся на 2. программа получает числа. признак окончания ввода 0. количество чисел не превышает 1000. введенные числа не превышают 30000. программа должна вывести одно число - минимальное,оканчивающееся на 2,если таких нет,вывести на экран об этом сообщение.

Показать ответ
Ответ:
Arino4ka7381
Arino4ka7381
05.10.2020 18:16
Var
A,m:integer;

Begin
m:=32767;
Repeat
Read(A);
if (A mod 10 = 2)and(A < m) then m:=A;
Until A=0;

if m mod 2 = 0 then WriteLn(m)
else WriteLn('Чисел, оканчивающихся двойкой нет.')
End.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота