В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
rjt54
rjt54
23.01.2022 20:21 •  Информатика

Плз! на языке паскаля составьте программу, которая по введенному вами k – числу грибов, печатает фразу «мы нашли в лесу k грибов, причем согласовывает окончание слова «гриб» с числом k.

Показать ответ
Ответ:
Chelovek987654321
Chelovek987654321
05.10.2020 20:47
Var
k:integer;
Begin
Write('k = ');ReadLn(k);
Write('Мы нашли ',k);
if (k>9)and(k<20) then WriteLn(' грибов')
else
   Case k mod 10 of
   0,5..9:WriteLn(' грибов');
   1:WriteLn(' гриб');
   2..4:WriteLn(' гриба');
   End;
End.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота