В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
Zen201
Zen201
05.03.2020 16:51 •  Информатика

Получив на вход натуральное число x (x > 100), программа печатает число M. Укажите наименьшее значение переменой x, при вводе которого алгоритм печатает 26.
var x, L, M: integer;
begin
readln(x);
L := x;
M := 52;
while L <> M do
if L > M then
L := L – M
else
M := M – L;
writeln(M)
end.

Показать ответ
Ответ:
chernecov1977
chernecov1977
08.04.2023 19:44
Линейный алгоритм – описание действий, которые выполняются однократно в заданном порядке. Исполнитель выполняет действия последовательно, одно за другим в том порядке в котором они следуют.

Блок-схема представляет собой совокупность символов, соответствующих этапам работы алгоритма и соединяющих их линий. Пунктирная линия используется для соединения символа с комментарием. Сплошная линия отражает зависимости по управлению между символами и может снабжаться стрелкой. Стрелку можно не указывать при направлении дуги слева направо и сверху вниз.

Ветвление – это команда алгоритма, в которой делается выбор, выполнять или не выполнять какую-нибудь группу команд в зависимости от условий. Ветвление используется в двух случаях:
Когда в алгоритме есть действия, которые иногда нужно пропускать (в зависимости от какого-то условия).
Когда в алгоритме нужно записать выбор тех или иных действий (в зависимости от какого-нибудь условия).
0,0(0 оценок)
Ответ:
som1712
som1712
11.06.2021 21:18
type
   massiv = array [2..21] of integer;
var
    mass : massiv;
    i, summa : integer;
 
begin
   summa := 0;
   for i:=2 to 21 do
        begin
           mass[i]:=i;
           if (mass[i] mod 2 = 0) then
              summa := summa + mass[i]
        end;
   writeln('Сумма четных эл-тов равна : ', summa);
   readln;
end.

program z;
var
        a : array[2..21] of integer;
        i,summ : integer;
        b : array[2..21] of integer;

begin
        for i:= 2 to 21 do
        begin
         a[i]:=i;
        end;

        for i:=2 to 21 do
          begin
          if a[i] mod 2 = 0 then
                begin
                  b[i]:=a[i];
                end;

          end;

        summ:=0;
        for i:=2 to 21 do
        begin
         summ:=summ+b[i];
        end;
        Writeln(summ);
        readln;

end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота