В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
dinkooo96
dinkooo96
27.11.2020 08:34 •  Информатика

Пользователь вводит с клавиатуры количество рядов прямоугольников. программа на питоне в идле разработке

Показать ответ
Ответ:
aliskaiii
aliskaiii
06.05.2021 19:29

using System;

using System.Collections.Generic;

using System.Linq;

using System.Text;

 

namespace ConsoleApplication1

{

    class Program

    {

        static void Main(string[] args)

        {

            //Напишите программу,которая в последовательности целых чисел определяет количество чисел,кратных 5 или 9.

            //Программа получает на вход целые числа,количество введённых чисел неизвестно,последовательность чисел заканчивается числом 0.

            //Количество чисел не превышает 1000.Введённые числа по модулю не превышают 30 000.Программа должна вывести одно число:количество чисел,кратных 5 или 9.

            int n = 0; // количество

            int a = int.Parse(Console.ReadLine());

            while (a != 0)

            {

                if (a % 5 == 0 || a % 9 == 0)

                    n++;

                a = int.Parse(Console.ReadLine());

            }

            Console.WriteLine(n);

            Console.ReadKey();

        }

    }

}

 

 

0,0(0 оценок)
Ответ:
BlackNeck730
BlackNeck730
21.05.2022 12:28
#include <iostream>
using namespace std;

int Max(int a, int b)
{
if (a>b) return a;
    else return b;
}

int Min(int a, int b)
{
if (a<b) return a;
    else return b;
}

char F(int a, int b)
{
if (a<b) return '<';
    else if (a>b) return '>';
    else return '=';
}

int main()
{
    int x, y;
    cout << "x = ";
    cin >> x;
    cout << "y = ";
    cin >> y;
    cout << "Max = " << Max(x,y) << "\n";
    cout << "Min = " << Min(x,y) << "\n";
    cout << x << F(x,y) << y << "\n";
    system("Pause");
    return 0;
}

Пример:
x = 15
y = 29
Max = 29
Min = 15
15<29
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота