В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
Heda0101
Heda0101
14.07.2020 07:27 •  Информатика

Приветик друзья с кодом, а то никак не пойму как его записать на паскаль.
— Составить программу, которая формирует массив P из 24 элементов, в котором элементы с 1 по 10 являются кубами своих порядковых номеров, элементы с 10 по 24 равны периметрам квадратов со сторонами равными соответственно 10, 11,12, …, 24. Массив вывести в строку.

Показать ответ
Ответ:
dilnaramusaeva
dilnaramusaeva
11.12.2022 22:17
Прежде чем писать программу, попробуем ее формализовать.
Мы знаем, что периметр прямоугольника равен Р = 2*(a+b), а площадь равна S=a*б, где a и b - две стороны прямоугольника.
Тогда b =S/a, а периметр P =2a +2b или 2a+2S/a. Отсюда
a*P = 2a² +2S. Имеем квадратное уравнение:
a²-a*P/2+S=0, решая которое относительно а (сторона прямоугольника) при известных коэффициентах P и S, получим значение сторон прямоугольника.
В программе я не проверяю, что введены именно положительные периметр и площадь, надеясь на внимательность вводящего данные.
Итак:
program storona;
uses crt;  { используем экран}
var         
  b,P,S,d,x1,x2: real;  {наши переменные}
begin
  clrscr; {чистим экран}
  write('Wwedite perimetr  P: ');
  readln(P);
  write('Wwedite ploshad S: ');
  readln(S);
  {Вычисляем дискриминант}
  b:=-P/2;
  d:= b*b - 4*S;
  if d > 0 then  {Если дискриминант >0 - все хорошо}
begin
  x1:= (-b + sqrt(d))/2;
  x2:= (-b - sqrt(d))/2;
  writeln('Storona1 = ',x1:0:2); {ответ с двумя знаками после запятой}
  writeln('Storona2 = ',x2:0:2);
end;
{Если дискриминант равен 0, то тоже неплохо: у нас квадрат}
  if d = 0 then
begin
  x1:= -(b/2);
  writeln('Storona1 = ',x1:0:2);
  writeln('Storona2 = ',x1:0:2);
end;
{Если дискриминант меньше 0, плохо, выводим сообщение}
  if d < 0 then
begin
  writeln('Ошибка в данных);
end;
  readln;
end.
0,0(0 оценок)
Ответ:
seetneek
seetneek
17.01.2022 23:06
А) однозначно интерпретируется, увязывается с базой знаний т.е не противоречит, несет полезный смысл т.е получатель может ей воспользоваться.
б) его содержимое понятно для человека и он физически может им воспользоваться или сможет или мог ранее но не знал. Важно чтобы информация сообщения проиндексировалась мозгом, увязалась с уже имеющимися данными. на неё мозгу необходимо составить как можно больше ссылок и связей с другими данными, чтобы человек воспользовался этой информацией в будущем и в разных ситуациях а не  не только в данной или подразумеваемой сообщением
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота