В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
AnnLage
AnnLage
19.08.2020 16:52 •  Информатика

Проблема та-же но осталось всего 1 (остальные 4 сделал сам вот само : напишите программу которая в последовательности целых чисел определяет их количество и подсчитывает сумму положительных чётных чисел , не превосходящих 256. программа получает на вход целые числа, количество которых неизвестно, последовательность чисел заканчивается числом 0(0 - признак окончания ввода,не входит в последовательность).

Показать ответ
Ответ:
4236fjfjfuf
4236fjfjfuf
06.10.2020 13:04
Var a,n: integer; s:longint;
begin
  s:=0;
  n:=0;
  readln(a);
  while a<>0 do begin
     n:=n +1;
     if (a mod 2=0) and (a>0) and (a<=256) then s:=s+a;
     readln(a);
     end;
writeln(n);
writeln(s)
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота