Программа Packal !! Автоморфным называется такое число, которое равно последним цифрам своего квадрата. Например:
52=25; 252=625
Требуется найти все автоморфные числа в интервале [m, n].
Входные данные
С клавиатуры вводятся значения целых чисел m и n
Выходные данные
на экран выводятся числа из интервала [m, n], являющиеся автоморфными. Если таких чисел нет, на экран выводится число 0
var n,i:integer;
t:array[1..100] of real;
a,b:real;
begin
readln(n);
readln(a);
readln(b);
for i:=1 to n do
begin
t[i]:=(b-a)/n;
write(t[i],' ');
end;
end.
2) Program n1;
var a:array[1..100] of integer;
n,i:integer;
k:real;
begin
read(n);
k:=0;
for i:=1 to n do
read(a[i]);
for i:=1 to n do
if a[i] mod 2 <> 0 then
k:=k+1;
writeln;
writeln('кол-во нечет. чисел равно ',k,'');
end.
6) Program n1;
var a:array[1..100] of real;
i,n:integer;
s,sr:real;
begin
read(n);
for i:=1 to n do
read(a[i]);
s:=0;
sr:=0;
for i:=1 to n do
s:=s+a[i];
sr:=s/n;
writeln('сред. арифметическое равно ',sr,'');
end.
7) Program n1;
var a:array[1..100] of real;
i,n:integer;
min,max:real;
begin
read(n);
for i:=1 to n do
read(a[i]);
min:=a[1];
for i:=2 to n do
if a[i]<min then
min:=a[i];
max:=a[1];
for i:=2 to n do
if a[i]>max then
max:=a[i];
writeln('максимальный элемент равен ',max,'');
writeln('минимальный элемент равен ',min,'');
end.
8) Program n1; var a:array[1..100] of real; i,n:integer; min,max,nom1,nom2:real; begin read(n); for i:=1 to n do read(a[i]); min:=a[1]; nom1:=1; for i:=2 to n do if a[i]<min then begin min:=a[i]; nom1:=i; end; max:=a[1]; nom2:=1; for i:=2 to n do if a[i]>max then begin max:=a[i]; nom2:=i; end; writeln('максимальный элемент равен ',max,', его номер ',nom2,''); writeln('минимальный элемент равен ',min,', его номер ',nom1,''); end.
9) Program n1; var a:array[1..100] of real; i,n:integer; min,max,s,sr:real; begin read(n); randomize; for i:=1 to n do begin a[i]:=random(100)+1; write(a[i],' '); end; writeln; s:=0; sr:=0; for i:=1 to n do s:=s+a[i]; sr:=s/n; writeln('ср. арифм. = ',sr,''); min:=a[1]; for i:=2 to n do if a[i]<min then min:=a[i]; max:=a[1]; for i:=2 to n do if a[i]>max then max:=a[i]; writeln('максимальный элемент равен ',max,''); writeln('минимальный элемент равен ',min,''); end.
Допустим, массив уже задан, поэтому его ввод писать не буду. Kol - количество элементов массива
var
mas, mas_ob: array[0..999] of integer;
i, kol_null, sum, sum_nech, sum_ch, pp, i1, kol, max: integer;
begin
kol_null := 0;
sum := 0;
sum_nech := 0;
sum_ch := 0;
i1 := 0;
max := -10000;
for i := 0 to kol do
begin
if mas[i] <> 0 then kol_null += 1; //2
sum += mas[i]; //3
if mas[i] mod 2 <> 0 then sum_nech += mas[i];//4
if mas[i] mod 2 = 0 then sum_ch += mas[i]; //5
if mas[i] < 0 then mas[i] := abs(mas[i]); //6
if mas[i] mod 21 = 0 then mas[i] := 1; //7
if mas[i] > max then max := mas[i]; //11
end;
pp := mas[0];//8
mas[0] := mas[kol]; //8
mas[kol] := pp;//8
for i := kol downto 0 do //10
begin
mas_ob[i] := mas[i];
i1 += 1;
end;
writeln('Количество ненулевых элементов: ', kol_null);
writeln('Сумма всех элеметов: ', sum);
writeln('Сумма нечетных элеметов: ', sum_nech);
writeln('Сумма четных элеметов: ', sum_ch);
writeln('Максимальный элемент: ', max);
end.