В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
2302fgdg
2302fgdg
30.05.2022 14:24 •  Информатика

Программа с массивами c++/c. существует массив t[1..n,1..n] с целыми числами. составьте программу, которая будет вычислять произведение ненулевых элементов над диагональю и считать отрицательные элементы под главной диагональю главной матрицы т. 1) и алгоритм решения если можно.

Показать ответ
Ответ:
helpmepleasehelpls
helpmepleasehelpls
07.10.2020 09:39
/*VS C++*/
#include <iostream>
#include <time.h>

using namespace std;

int main() {
    int T[255][255];
    int N, sum, mult;

    cout << "Vvedite N = "; cin >> N;
    cout << "***Random matrix***" << endl;
    srand(time(NULL));

    //Генерация массива
    for (int i = 0; i < N; i++) {
        for (int j = 0; j < N; j++) {
            T[i][j] = rand() % 41 + (-20);
            printf("%4.0d ", T[i][j]);
        }
        cout << endl;
    }

    //Сумма отрицательных над главной
    sum = 0;
    for (int i = 1; i < N; i++) {
        for (int j = 0; j < N; j++){
            if (j == i - 1) {
                if (T[i][j] < 0){
                    sum = sum + T[i][j];
                }
            }
        }
    }
    cout << "Summa = " << sum << endl;

    //Произведение ненулевых под главной
    mult = 1;
    for (int i = 0; i < N; i++) {
        for (int j = 1; j < N; j++) {
            if (j == i + 1) {
                if (T[i, j] != 0) {
                    mult = mult * T[i][j];
                }
            }
        }
    }
    cout << "Proizvedenie = " << mult << endl;
   
    system("pause");
    return 0;
}

Программа с массивами c++/c. существует массив t[1..n,1..n] с целыми числами. составьте программу, к
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота