Программа такая: есть завод, на котором производят ручки и запаковывают их в коробки. Он производит определенное количество ручек P, в одну коробку B помещается K ручек, остаток ручек O кладется в последнюю коробку L. Например, если завод произвел 100 ручек, а в коробку помещается 8 ручек, то всего будет 12 полных коробок, а в последней неполной коробке будет 4 ручки. Напишите программу, при запуске которой пользователь вводит количество произведенных ручек и количество ручек в коробке, а программа выдает количество полученных полных коробок и количество ручек в последней неполной коробке очень нужно
#include <iostream>
#include <map>
#include <vector>
#include <set>
#include <stack>
#include <bitset>
#include <queue>
#include <algorithm>
#include <iomanip>
#include <unordered_map>
#include <unordered_set>
#include <cmath>
#include <cassert>
#include <random>
#pragma GCC target("avx,avx2,sse3,ssse3,sse4.1,sse4.2,tune=native")
#pragma GCC optimize(3)
#pragma GCC optimize("O3")
#pragma GCC optimize("inline")
#pragma GCC optimize("-fgcse")
#pragma GCC optimize("-fgcse-lm")
#pragma GCC optimize("-fipa-sra")
#pragma GCC optimize("-ftree-pre")
#pragma GCC optimize("-ftree-vrp")
#pragma GCC optimize("-fpeephole2")
#pragma GCC optimize("-fsched-spec")
#pragma GCC optimize("-falign-jumps")
#pragma GCC optimize("-falign-loops")
#pragma GCC optimize("-falign-labels")
#pragma GCC optimize("-fdevirtualize")
#pragma GCC optimize("-fcaller-saves")
#pragma GCC optimize("-fcrossjumping")
#pragma GCC optimize("-fthread-jumps")
#pragma GCC optimize("-freorder-blocks")
#pragma GCC optimize("-fschedule-insns")
#pragma GCC optimize("inline-functions")
#pragma GCC optimize("-ftree-tail-merge")
#pragma GCC optimize("-fschedule-insns2")
#pragma GCC optimize("-fstrict-aliasing")
#pragma GCC optimize("-falign-functions")
#pragma GCC optimize("-fcse-follow-jumps")
#pragma GCC optimize("-fsched-interblock")
#pragma GCC optimize("-fpartial-inlining")
#pragma GCC optimize("no-stack-protector")
#pragma GCC optimize("-freorder-functions")
#pragma GCC optimize("-findirect-inlining")
#pragma GCC optimize("-fhoist-adjacent-loads")
#pragma GCC optimize("-frerun-cse-after-loop")
#pragma GCC optimize("inline-small-functions")
#pragma GCC optimize("-finline-small-functions")
#pragma GCC optimize("-ftree-switch-conversion")
#pragma GCC optimize("-foptimize-sibling-calls")
#pragma GCC optimize("-fexpensive-optimizations")
#pragma GCC optimize("inline-functions-called-once")
#pragma GCC optimize("-fdelete-null-pointer-checks")
using namespace std;
void solve();
int main() {
ios::sync_with_stdio(0);
cin.tie(0);
#ifdef DEBUG
freopen("input.txt", "r", stdin);
#endif
solve();
}
const int N = 3e5 + 100, A = 2e5 + 100, MOD = 1e9 + 7, INF = 1e18;
void solve() {
vector < vector < int > > a(5, vector < int >(10));
long long sum = 0;
for (int i = 0; i < a.size(); i++) {
for (int j = 0; j < a[i].size(); j++) {
cin >> a[i][j];
sum += a[i][j];
}
}
cout << sum;
}
Объяснение:
1)2D графика более реалистично передает мысль, чем рисунок от руки
2) 2D:
О разнообразии на рынке
Adobe Photoshop 7.
Adobe Illustrator 10.
CorelDRAW Graphics Suite 11.
Corel Painter 7.
Ulead PhotoImpact 8.
Jasc Paint Shop Pro 7.
Expression 3.
3D:
Autodesk 3ds Max. 3ds Max — одна из старейших и самых распространенных программ для 3D-моделирования. ...
Maya. ...
Blender. ...
ZBrush.
3 )пиксельных 8-битных
4 ) Вид
Панель инструментов
Расширенная
5 )3D графика имеет много ограничений и требований к построению сцены и кадра. 2D графика проще в создании и может показать больше типов сцен. 3D требует большего профессионализма (подбор сцены, установка камер, движения в сцене, «вылеты» объектов, близкие планы и т. д.).
6)я хз
7)я хз
8)я хз
9)Инструмент Следуй за мной может создавать обьемные фигуры, двигая их вдоль любой выделенной линии
10)Autodesk Maya.
Adobe Animate.
Synfig Studio.
Blender.
Autodesk Autocad.
DWG TrueView.
Mathcad.