В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
Kategio123
Kategio123
29.10.2021 22:50 •  Информатика

Программа в С++ Метеоритный дождь

В солнечный декабрьский зимний день ничего не предвещало беды. Так думала и команда, которая решила написать очередной контест. Для написания контеста организатор подготовил несколько компьютеров. Все они пронумерованы числами от 1 до 113. Однако, когда команда пришла к началу контеста, случилось так, что почти все компьютеры были заняты - все, кроме 4-х. Команде нужно было быстро выбрать компьютер, и она уже начала справляться со сложной проблемой выбора, как вдруг по радио объявили, что сегодня будет метеоритный дождь. Причём достоверно известно, что на три из четырёх свободных компьютеров упадёт по метеориту. Так как команда не хочет быть раздавленной метеоритом, ей необходимо выбрать безопасный компьютер. Однако выбор - сложный и долгий процесс, а команда хочет хорошо выступить, поэтому им нельзя терять время ещё на один поиск им!

Входные данные:
В первой строке вам даны 4 числа - номера свободных компьютеров. Все они - различные целые числа, не превосходящие 113.

Во второй строке вам даны 3 числа - номера компьютеров, на которые упадёт метеорит. Гарантируется, что эти номера различны и что все соответствующие компьютеры свободны.

Выходные данные:
Выведите единственное число - номер компьютера, который следует выбрать команде.

Показать ответ
Ответ:
Gummanitarii
Gummanitarii
20.02.2023 01:30

<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01//EN" "http://www.w3.org/TR/html4/strict.dtd">

<html>

<head>

 <meta http-equiv="Content-Type" content="text/html; charset=utf-8">

 <title>Твой title</title>

  <style type="text/css">

  TABLE {

   background: maroon; /* Цвет фона таблицы */

   color: white; /* Цвет текста */

  }

  TD {

   background: navy; /* Цвет фона ячеек */

  }

 </style>

</head>

<body>

 <h1>Заголовок</h1>

 <p>Первый абзац.</p>

 <p>Второй абзац.</p>

 <Img src="https://million-wallpapers.ru/wallpapers/1/55/506744950768048/biryuzovyj-gornoe-ozero.jpg" Width="200" Height="150">;

<ul>

<p><a href="https://superresheba.by/">resheba</a></p>

 <li>1</li>

 <li>2</li>

 <li>3</li>

 <li>4</li>

</ul>

<table>

<table cellpadding="4" cellspacing="1">

  <tr><th>Заголовок 1</th><th>Заголовок 2</th></tr>

  <tr><td>Ячейка 3</td><td>Ячейка 4</td></tr>

</table>

</body>

</html>

Объяснение:

P.S css добавил в этом же коде (не в отдельном файле).

И картинка по ссылке. Ее тоже можно было бы в отдельный файл записать(по необходимости).

0,0(0 оценок)
Ответ:
zavet3427
zavet3427
03.03.2022 17:38

import random

# Определяем список учеников

student_list = ["Александр", "София", "Мария", "Максим", "Михаил", "Артём", "Анна", "Даниил", "Иван", "Виктория",

               "Алиса", "Анастасия", "Дмитрий", "Полина", "Елизавета", "Александра", "Дарья", "Екатерина", "Кирилл"]

# Создаем цикл while

while True:

   # Создаем пользовательский ввод

   sort_type = input("Выберите метод сортировки учеников (r - случайно, a - в алфавитном порядке, ar - в алфавитном "

                     "порядке обратно): ")

   # Если выбран метод сортировки "r", сортируем список случайно и прерываем выполнение текущего цикла

   if sort_type == "r":

       random.shuffle(student_list)

       print(student_list)

       break

   # Если выбран метод сортировки "a", сортируем список в алфавитном порядке и прерываем выполнение текущего цикла

   elif sort_type == "a":

       student_list.sort()

       print(student_list)

       break

   # Если выбран метод сортировки "ar", сортируем список в алфавитном порядке обратно и прерываем выполнение

   # текущего цикла

   elif sort_type == "ar":

       student_list.sort(reverse=True)

       print(student_list)

       break

   # Если выбран неопределенный сортировки, выводим ошибку и возвращаемся к пользовательскому вводу

   else:

       print("Неизвестный метод сортировки.")


задачу по инфе на языке PYTHON! import random x = random.randint(1, 10) Преподаватель опрашивает уче
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота