с задания в Python.
3. Опишите на языке Python строковый тип переменной (буквенный)
4. Опишите на языке Python целочисленный тип переменных
5. Опишите на языке Python команду, позволяющую вводить данные с клавиатуры
6. Опишите на языке Python команду, позволяющую вывести информацию на экран монитора.
7. Опишите на языке Python вещественный тип переменных
8. Опишите на языке Python следующее условие: "если значение переменной s больше значения переменной d, то максимуму m присвоить значение переменной s". Примечание: Отступы обязательно показывать( для обозначения отступа можно использовать символ #), синтаксис языка тоже никто не отменял
9. Напишите программу, вычисляющую площадь и периметр прямоугольника со сторонами a и b. если площадь больше периметра, то программа должна вывести значение площади, а если периметр больше, то программа должна вывести значение периметра. Оформление программы: см задание 8
Современный PascalABC.NET
begin
var (a, b) := ReadInteger2('Введите a и b:');
if a > b then
Print(a, b)
else
Print(b, a)
end.
Старенький Free Pascal
var
a, b: integer;
begin
Write('Введите a и b: ');
Readln(a, b);
if a > b then
Write(a, ' ', b)
else
Write(b, ' ', a)
end.
Turbo Pascal для современников мамонтов
program ABC;
uses Crt;
var
a, b: integer;
begin
ClrScr;
Write('Введите a и b: ');
Readln(a, b);
if a > b then
Write(a, ' ', b)
else
Write(b, ' ', a);
ReadKey;
end.
N = 2^i, где N - количество символов в алфавите, а i - вес каждого символа алфавита в битах.
У нас 128 символов, значит, N = 128, используя формулу, определяем вес символа в алфавите:
128 = 2^i => i = 7 бит
(Кстати, если здесь всё четко получилось (2^7 = 128), то если у тебя N= 127, то i нужно округлять в большую сторону: здесь i тоже будет равен 8 бит, или если N=129, то i =9 бит)
Теперь вычисляем сколько информации содержится в сообщении, умножив вес символа на количество символов:
8 × 40 = 320 бит
ответ: 320 бит