В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
7gklass2017
7gklass2017
25.12.2022 02:54 •  Информатика

Программисты и те кто хорошо знает информатику Решите Паскаля!Скрин с низу

A) Определить значение переменной

f после выполнения фрагмента

алгоритма

i:=0; f:=1;

while (i < 15)

{

i:=i+4;

f:= 2+1+ i;

}

E) На известном вам языке программирования напишите программу Даны три целых числа Вычислить сумму отрицательных чисел

Код программы


Программисты и те кто хорошо знает информатику Решите Паскаля!Скрин с низуA) Определить значение пер

Показать ответ
Ответ:
WWW2014
WWW2014
09.04.2021 09:32
// PascalABC.NET 3.3, сборка 1634 от 14.02.2018
// Внимание! Если программа не работает, обновите версию!

begin
  var L:='бвгджзйлмнр'.ToList;
  var s:=ReadlnString;
  var p:=Pos('.',s);
  if p>0 then s:=s[:p];
  var aw:=s.ToWords;
  var i:=1;
  while i<=aw.Length-1 do begin
    var L1:=L.ToList;
    foreach var c in L1 do
      if not aw[i-1].Contains(c) then L.Remove(c)
      else
        if aw[i].Contains(c) then L.Remove(c);
    i+=2
    end;
  if L.Count>0 then L.Println(',')
  else Writeln('Нет звонких согласных, удовлетворяющих условию')
end.

Примеры
бодро    шагаем  дрова несем        друзья  товарищи
д

вместе весело    шагать    по   просторам
Нет звонких согласных, удовлетворяющих условию

   багряный   закат красный   восход
й,н,р
0,0(0 оценок)
Ответ:
olesahshhahas
olesahshhahas
09.04.2021 09:32
Var s:string;
m,mn,m1,m2:set of char;
i,k,l:integer;
begin
writeln('Введите последовательность русских слов:');
readln(s);
m:=['Б','б','В','в','Г','г','Д','д','Ж','ж','З','з','Й','й','Л','л','М','м','Н','н','Р','р'];
k:=0;
for i:=1 to length(s) do
 if not (s[i] in ['А'..'Я','а'..'я',' ','.']) then k:=k+1;
if k>0 then writeln('Ошибка ввода')
else begin
 while pos('  ',s)>0 do delete(s,pos('  ',s),1);
 if s[length(s)]='.' then s[length(s)]:=' ';
 k:=0; mn:=[]; m1:=m; m2:=m;
 for i:=1 to length(s) do
  begin
  mn:=mn+[s[i]];
  if s[i]=' ' then
   begin
   k:=k+1;
   if k mod 2=1 then m1:=m1*mn else m2:=m2*mn;
   mn:=[];
   end;
  end;
 mn:=m1-m2;
 print(mn);
     end;
end.

Пример:
Введите последовательность русских слов:
напечатать в   алфавитном порядке    звонкие буквы.
{н} 
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота