В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
serofimtimoxa
serofimtimoxa
13.03.2021 11:05 •  Информатика

PYTHON. Напишите программу для удаления каждого третьего элемента из целочисленного списка и печати результирующего списка, пока список не станет пустым. Первоначальный список целых чисел вводится в одной строке через пробел.

Показать ответ
Ответ:
Eskhere
Eskhere
09.07.2021 11:35

Python

a=[int(i) for i in input().split()]

while len(a)>2:

   z=0

   for i in range(2,len(a)-z,3):

       a.pop(i-z)

       z+=1

   print(a)

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20

[1, 2, 4, 5, 7, 8, 10, 11, 13, 14, 16, 17, 19, 20]

[1, 2, 5, 7, 10, 11, 14, 16, 19, 20]

[1, 2, 7, 10, 14, 16, 20]

[1, 2, 10, 14, 20]

[1, 2, 14, 20]

[1, 2, 20]

[1, 2]

>>>

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота