В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
Mila672
Mila672
09.05.2020 16:31 •  Информатика

Python , напишите решение этих , : 1. если введённое число p оканчивается на 7, то вывести это число, увеличенное в десять раз. написать программу и в качестве ответа скопировать код в окно для предоставления ответа. 2. если первая цифра введённого трёхзначного числа m чётное, то разделить её на два и вывести полученное число. написать программу и в качестве ответа скопировать код в окно для предоставления ответа. 3. если средняя цифра введённого трёхзначного числа больше 5, то заменить её на последнюю цифру числа. написать программу и в качестве ответа скопировать код в окно для предоставления ответа.

Показать ответ
Ответ:
Dan20147
Dan20147
15.08.2022 16:35

(АСУ) , совокупность математических методов, технических средств (ЭВМ, средств связи, устройств отображения информации и т. д.) и организационных комплексов, обеспечивающих рациональное управление сложным объектом (процессом) в соответствии с заданной целью. АСУ состоит из основы и функциональной части. В основу входят информационное, техническое и математическое обеспечение. К функциональной части относят набор взаимосвязанных программ, автоматизирующих конкретные функции управления (планирование, финансово-бухгалтерскую деятельность и др.). Различают АСУ объектами (технологическими процессами - АСУТП, предприятием - АСУП, отраслью - ОАСУ) и функциональными автоматизированными системами, напр., проектирования, расчетов, материально-технического и др. обеспечения.

0,0(0 оценок)
Ответ:
tomchakd
tomchakd
23.07.2020 03:17
/*Дан массив X(N,M) .Найти среднее арифметическое тех строк массива, первый элемент которых положительный*/#include <iostream>#include <time.h>#define M 5#define N 5using namespace std;
void printArray(int *mas, int n,int m)//инициализация и вывод массива { srand(time(0)); for (int i = 0; i < n; i++) { for (int j = 0; j < m; j++) { *mas = rand() % 21-10; cout << *mas << "\t"; mas++; } cout << endl; }}

void srArray(int mas[][M], int n)//нахождение и подсчет тех строк, где первый элемент положительный{ int a; double sum = 0; for (int i = 0; i < n; i++) { double sr = 1; if (mas[i][0] > 0) { for (int j = 0; j < M; j++) { sum += mas[i][j]; } sr = sum / M; cout << "Ср элеменитов " << i + 1 <<  "-й строки = " << sr << endl; } else ; }
}

void main()//основная функция{ setlocale(LC_ALL, "rus"); int x[N][M]; printArray(&x[0][0], N, M); cout << endl; cout << ""<<endl; srArray(x, N); system("pause");}
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота