PYTHON
Решить в действительных числах уравнение ax2 + bx + c = 0
Входные данные
На вход программе подаются a, b, c (a, b, c целые, по модулю не превосходят 30 000).
Выходные данные
Выдать код ситуации и значения корней:
•–1 — бесконечное множество решений;
• 0 — нет действительных корней;
• 1 — уравнение вырождается в линейное, выдать x;
• 2 — уравнение квадратное, два различных корня, выдать x1 и x2;
• 3 — уравнение квадратное, кратный корень, выдать x;
Значения корней выводить с двумя знаками после десятичной точки в порядке возрастания.
max,min,s,i,n,maxi,mini:integer;
begin;
randomize;
max:=-1;
min:=101;
readln(n);
setlength(ar,n+1);
writeln('Array:');
for i:=1 to n do
begin;
ar[i]:=random(100);
write(ar[i]:4);
if max<ar[i] then
begin;
max:=ar[i];
maxi:=i;
end;
if min>ar[i] then
begin;
min:=ar[i];
mini:=i;
end;
s:=s+ar[i];
end;
ar[maxi]:=s;
ar[mini]:=s;
writeln;
writeln('Final array:');
for i:=1 to n do
write(ar[i]:4);
end.
2)var ar:array of integer;
k,h,i,s:integer;
f:real;
begin;
randomize;
readln(h);
setlength(ar,h+1);
writeln('Array:');
for i:=1 to h do
begin;
ar[i]:=random(100)-50;
write(ar[i]:4);
if (ar[i]>0) and (ar[i] mod 2=0) then
begin;
inc(k);
s:=s+ar[i];
end;
end;
f:=s/k;
writeln;
writeln('Result:',f);
end.
Соблюдение простых правил избежать многих проблем
1. Советуйтесь с родителями.
Обязательно спрашивайте родителей о незнакомых вещах в Интернете. Например, о получении странного сообщения или предложения.
2. Храните личную информацию в тайне!
Не пишите в Интернете (в том числе в играх и на своих страничках в социальных сетях) личную информацию, такую как: домашний адрес, номера домашнего и мобильного телефонов, адрес электронной почты, место учёбы.
3. Не открывайте подозрительные файлы.
Не стоит скачивать или открывать неизвестные, а особенно присланные незнакомцами файлы. Это может привести к заражению компьютера вирусами.
4. Не переносите виртуальные знакомства в реальность.
Если виртуальный знакомый хочет пообщаться или встретиться с вами в реальной жизни – ни в коем случае не соглашайтесь. Люди в сети не всегда рассказывают правду о себе и целях своих поступков. Обязательно сообщите о таком предложении родителям.
5. Не спешите отправлять sms.
Если за скачивание картинки или музыки из Интернета, или для покупки игровых ценностей просят отправить sms, спрашивайте разрешение у родителей для отправки подобных сообщений.
6. Будьте дружелюбны.
Не нужно писать грубых слов, потому что читать их так же неприятно, как и слышать, к тому же за грубости на ваш аккаунт могут быть наложены ограничения.
7. Храните пароли в секрете.
Храните в секрете свои пароли от страничек, почты и игр от всех, кроме родителей.