В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История

PYTHON
Делители числа
Напишите программу, которая отображает все делители числа N.
Входные данные: вводится единственное натуральное число n.
Выходные данные: на одной строке вывести все делители данного числа. Используйте для вывода параметр
end = " " с командой print(). Пример: print(x, end = " ").
Пример 1
Ввод:
12
Вывод:
1 2 3 4 6 12
В пайтоне

Показать ответ
Ответ:
evgehamorozov
evgehamorozov
14.10.2020 07:23

a = int(input("Введи число: "))

for i in range(1,a+1):

   if a%i == 0:

       print(i,end = " ")


PYTHONДелители числа Напишите программу, которая отображает все делители числа N. Входные данные: вв
PYTHONДелители числа Напишите программу, которая отображает все делители числа N. Входные данные: вв
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота