{Pyton}Задание У вас есть персонаж, обладающий рядом
и статов.
Напишите программу по заданным условиям:
1. Персонаж имеет набор статов: strength, dexterity, intelligence, wisdom, charisma. Каждая стата имеет свой запас.
Значения запасов каждой статы должны быть случайны – в пределах от 60 до 80 и быть представлены в списке
stats = []:
stats = []
attributes = 5
for i in range(attributes):
r = random.randint(60, 80)
stats.append(r)
2. В начале игры пользователю предоставляется возможность
однократно повысить одну стату на случайное количество
единиц – от 5 до 15:
select = int(input('Select: '))
select -= 1
stats[select] = stats[select] +
random.randint(5, 15)
Обратите внимание, что повышая одну стату на сгенерированное число, все остальные должны уменьшиться на
случайное значение в пределах от 5 до 15:
for i in range(len(stats)):
if i == select:
continue
stats[i] = stats[i] - random.randint(5, 15)
3. Персонаж обладает набором скилов: fireball, lightning,
silence, fire ward.
Использование каждого из них отнимает разное количество единиц статов, а именно:
Атрибуты /
Wisdom Charisma
Fireball 12 15 28 10 5
Lightning 7 13 15 30 10
Silence 23 10 12 7 18
Fire Ward 20 23 14 6 17
Занесите эти данные в список, чтобы в дальнейшем
воспользоваться ими в игре:
fireball = [12, 15, 28, 10, 5]
...
...
4. Предоставьте пользователю возможность использовать
скилы, например, по нажатию f применяется Fireball,
l – Lightning и т. д. После применения какой-либо из
запас статов будет уменьшаться, согласно
приведенной выше таблице.
Рассмотрим следующий пример:
1. Было Stats: 70 64 63 80 65.
2. Применили Fireball: 12 15 28 10 5.
3. Стало Stats: 58 49 35 70 60.
Следите за тем, чтобы элементы в списке stats = []
не стали отрицательными.
#include <iostream.h>
bool amafree(float x1, float x2, float x3, float x4, float y1, float y2, float y3, float y4, float dotx, float doty)
{float x[4],y[4],temp;
for(int i=0;i<4;i++)
for(int j=0;j<3;j++)
{
if(x[j]<x[j+1])
{
temp=x[j];
x[j]=x[j+1];
x[j+1]=temp;
temp=y[j];
y[j]=y[j+1];
y[j+1]=temp;
}
}
if (y[2]<y[3]) {temp=x[2];
x[2]=x[3];
x[3]=temp;
temp=y[2];
y[2]=y[3];
y[3]=temp; }//теперь мы упорядочили точки прямоугольника, чтобы понимать его как у меня на рисунке
x1=x[0];
x2=x[1];
x3=x[2];
x4=x[3];
y1=y[0];
y2=y[1];
y3=y[2];
y4=y[3];//так мне удобнее, потому что часть условий уже написал без всяких массивов
float k[10];
k[0]=(x1-x2)/(y1-y2);
k[1]=(x1-x3)/(y1-y3);
k[2]=(x3-x4)/(y3-y4);
k[3]=(x2-x4)/(y2-y4);//коэффициенты прямых, проходящих по сторонам прямоугольника
// if(k[0]!=k[2]||k[1]!=k[3]) {cout<<"Eto dazhe ne parallelogramm\n";return false;}//условие параллельности противолежащих сторон
// if(k[0]!=1/k[1]||k[2]!=1/k[3]) {cout<<"Eto dazhe ne pryamougolnik\n";return false;}//условие перпендикулярности смежных сторон
if(dotx<x[1])&&(dotx<x[2])&&(dotx<x3)&&(dotx<x4)||(doty<y1)&&(doty<y2)&&(doty<x3)&&(doty<x4)||//лежит точно вне
(dotx>1)&&(dotx>x2)&&(dotx>x3)&&(dotx>x4)||(doty>y1)&&(doty>y2)&&(doty>x3)&&(doty>x4)||//лежит точно вне
(dotx>x1)&&(dotx<x2)&&(dotx<x3)&&(dotx<x4)&&(doty-k[0]*dotx<0)||//нижний левый треугольник
(dotx>x1)&&(dotx<x2)&&(dotx<x3)&&(dotx<x4)&&(doty-k[1]*dotx>0)||//верхний левый
(dotx>x1)&&(dotx<x2)&&(dotx<x3)&&(dotx<x4)&&(doty-k[2]*dotx>0)||//верхний праввый
(dotx>x1)&&(dotx<x2)&&(dotx<x3)&&(dotx<x4)&&(doty-k[3]*dotx<0)//нижний правый
return false;
return true;
}
а)
монитор, клавиатура, мышка. Хотя можно изворотится и без мышки сделать, но это сложно.
Adobe photoshop, UltraISO
б)
подключить оборудование, открыть photoshop, смотри изображение, открываем сайт (https://online-audio-converter.com/ru/) и конвертируем видео в mp3, запускаем программу UltraISO
, В окно программы перетягиваем файлы которые нужно записать, Нажимаем на кнопку записи (иконка горящего диска), откроется еще одно окно, в котором нажимаем на «Записать» и ждем окончания процесса записи.
в) https://primtrud.ru/content/tehnika-bezopasnosti-pri-rabote-s-kompyuterom.html - правила работы за компьютером