РЕБЯТА на питоне)
Напишите программу, которая в последовательности натуральных чисел
определяет минимальное двузначное число, кратное 3. Программа получает на вход
натуральные числа, количество введённых чисел неизвестно, последовательность
чисел заканчивается числом –1 (–1 – признак окончания ввода, не входит в
последовательность).
Введённые числа не превышают 30 000. Программа должна вывести одно число:
минимальное двузначное число, кратное 3.
import java.util.Scanner;
public class Authenticator {
public static void main(String[] args) {
String login;
String password;
Scanner scan = new Scanner(System.in);
System.out.println("login:");
login = scan.next();
System.out.println("password:");
password = scan.next();
if(login.equals("user") && password.equals("qwerty")){
System.out.println("Authentication completed");
}else{
System.out.println("Invalid login or password");
}
scan.close();
}
}
Объяснение:
Краткий алгоритм этой программы:Импортируем класс Scanner(для ввода текста);В методе main создаем две переменные типа String и одну типа Scanner;Вводим значения при а;Если логин и пароль верны,то выводим Authentication completed. Иначе выводим Invalid login or password;Закрываем Scanner;using namespace std;
int main() {
int mat[3][3];
int k;
int size=0;
int * arr=0;
for(int i=0;i<3;i++){
for(int j=0;j<3;j++){
cin>>mat[i][j];
if (mat[i][j]>0){
arr=(int*)realloc(arr,sizeof(int)*(++size));
arr[size-1]=mat[i][j];
}
}
}
for(int i=0;i<size;i++){
cout<<arr[i];
}
delete arr;
cin.get();
cin.get();
return 0;
}