В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
Иван199928
Иван199928
30.03.2022 18:46 •  Информатика

Решать массивом. найти сумму элементов, принадлежащих промежутку от а до в (а и в вводить с клавиатуры). составить программу

Показать ответ
Ответ:
Tumkanator
Tumkanator
24.05.2020 15:09

Program n1;
Uses CRT;
Const n=20;
Var m: array[1..n] of integer;
i,a,s,b: integer;
begin
ClrScr;
Randomize;
For i:=1 to n do
begin
m[i]:=random(50);
write(m[i]:3);
end;
writeln;
writeln('Введите A и B');
readln(a,b);
For i:=a to b do
s:=s+m[i];
writeln('Сумма равна ',s);
readln
end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота