В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
lilyabelousova
lilyabelousova
22.04.2021 19:17 •  Информатика

Решение на языке c#.
с клавиатуры вводятся n чисел. составьте программу, которая определяет количество отрицательных, количество положительных и количество нулей среди введенных чисел.

Показать ответ
Ответ:
Данька0007
Данька0007
22.07.2020 11:17

static void Main(string[] args)

       {

           int countzero = 0;

           int countplus = 0;

           int countminus = 0;

           int N;

           Console.Write("Укажите сколько чисел ввести: ");

           N = Convert.ToInt32(Console.ReadLine());

           int[] mas = new int[N];

           for (int i = 0; i < N; i++)

           {

               Console.WriteLine("Введите {0}-й элемент", i + 1);

               mas[i] = int.Parse(Console.ReadLine());

           }

           for (int i = 0; i < N; i++)

           {

               if (mas[i] == 0)

               {

                   countzero++;

               }

               else if(mas[i] < 0)

               {

                   countminus++;

               }

               else if(mas[i] > 0)

               {

                   countplus++;

               }

           }

           Console.WriteLine();

           Console.WriteLine("Количество положительных элементов = " + countplus);

           Console.WriteLine("Количество отрицательных элементов = " + countminus);

           Console.WriteLine("Количество нулевых элементов = " + countzero);

           Console.ReadKey();

       }

   }

}

Объяснение:

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота