В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
Anna567894
Anna567894
15.01.2023 18:01 •  Информатика

Решил начинающий программист Вася Битиков ланшафтным дизайном заняться - оформить бабушкину клумбу оригинальным узором, уж очень бабушка Рита цветы любит. Купил Вася в магазине рассаду - желтенькие маргаритки (M) и синенькие васильки (W), начертил план клумбы, разбил его на горизонтальные (H) и вертикальные (V) рядочки и в каждой клеточке соответствующий цветок нарисовал. А чтобы весь рисунок не запоминать он программку написал, которая по номерам только некоторых рядочков (V1, H1, H2) и координатам клеточки (Vo и Ho) определяет какой цветок должен расти в данном месте клумбы.

Попробуйте и вы такую же программу написать.
Учтите, нумерация вертикальных рядочков начинается с крайнего левого, номер которого равен нулю, а горизонтальных - с самого верхнего рядочка, номер которого также равен нулю.
Входные данные:

В первой строке входного потока натуральное число V1 - координата вертикального рядочка (0 < V1 < 100) Во второй строке 2 натуральных числа разделенные пробелом H1, H2 - координаты горизонтальных рядочков (0 < H1 < H2 < 100) В третьей строке 2 натуральных числа разделенные пробелом Vo, Ho - координаты клеточки, для которой нужно определить вид цветка (0 < Vo, Ho < 100)

Пример входного файла (input.txt):

7
5 10
15 2

Выходные данные:

W

В выходной поток необходимо вывести одну большую латинскую букву, обозначающую вид цветка: M - маргаритка или W - василек.

Показать ответ
Ответ:
ksp86450
ksp86450
01.06.2022 21:01
Если считать отрицательные трехзначные, то сумма таких чисел в диапазонах от -999 до -100 и от 100 до 999 будет равна 0. Для только положительных:

//c циклом for
var s,i:integer;
begin
  for i:=100 to 999 do
    if i mod 77 = 0 then s:=s+i;
  writeln('Сумма трехзначных кратных 77: ',s);
end.

Тестовое решение:
Сумма трехзначных кратных 77: 5929

// с циклом while
var s,i:integer;
begin
  i:=100;
  while i<=999 do begin
    if i mod 77 = 0 then s:=s+i;
    i:=i+1;
  end;
  writeln('Сумма трехзначных кратных 77: ',s);
end.
0,0(0 оценок)
Ответ:
genri5673
genri5673
12.04.2023 20:03
1. При использовании палитры из 2^24 цветов для хранения цвета 1 пикселя используется 24 бита = 3 байта.
Пусть количество пикселей в рисунке K, тогда объем памяти, занимаемой одним рисунком = (K*3)/1024 + 128 Кбайт.
X = 8*(K*3/1024 + 128)+2.5*1024
2. При использовании палитры из 2^16 цветов для хранения цвета 1 пикселя используется 16 бита = 2 байта.
Объем памяти, занимаемой одним рисунком = (K*2)/1024 + 128 Кбайт.
X = 20*(K*2/1024 + 128)
8*(K*3/1024 + 128)+2.5*1024 = 20*(K*2/1024 + 128)
К = 65536 (количество пикселей в рисунке)
X = 20*(K*2/1024 + 128) = 20*(65536*2/1024 + 128) Кбайт = 
 20*(128 + 128) Кбайт = 5120 Кбайт = 5120/1024 Мбайт = 5 Мбайт
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота