В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История

Решить, 2. составьте блок-схему алгоритма(её не надо) и программу вычисления в массиве a(10) количества положительных элементов. 3. составьте программу заполнения массива, не используя клавиатуру, числами: 1, 3, 5, 7, 9, 11, 13, 15, 17, 19.

Показать ответ
Ответ:
katesmile7
katesmile7
30.09.2020 20:36

 2)

Program Massiv1;

var a:array[1..10] of real;

       i:integer;

       s:real;

begin

      clrscr;

       write('Введите элементы массива: ');

 

      s:=0;

 

      for i :=1 to 10 do

             begin

                  readln(a[i]);   

 

                  if  (a[i]>0) then s:=s+1;

 

           end;

writeln;

for i :=1 to 10 do     writeln(a[i]:3:3);   

 writeln('Количество положительных элементов:',s);

 readkey;

 

 end.

 

 

 3)

Program Massiv2;

var a:array[1..10] of integer;

       i,b:integer;  

  begin

       clrscr;

       b:=2; 

       for i :=1 to 10 do

             begin

                a[i]=i+b;

                 b:=b+1; 

 

                 write(a[i]:2); 

 

             end;   

readkey;

end.

 

 

 

 

 

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота