В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
nikmonastyrev
nikmonastyrev
30.01.2023 20:47 •  Информатика

Решить (pascal),составить программу: b-7 1) вычисления значения функции вычисления значения функции y=2*10'5 cos3x-v(x+1) при любых значениях х 2). дано расстояние в сантиметрах. найти число полных метров в нем и сколько это будет в дюймах (1 дюйм=2,54 см) 3) дано трехзначное число. найти: а) число сотен в нем; б)число десятков в нем; в) число единиц в нем; в) сумму его цифр.

Показать ответ
Ответ:
alioo
alioo
20.06.2021 07:06

X=[15,1,0,255,12,38,154,36,794,2,54,-69]  #массив

Z=[]  #пустой массив

#запоминаем первый элемент из массива X как минимальный и максимальный

minc=X[0]

minind=0

maxc=X[0]

maxind=0

k=-1  #переменная-счетчик

for i in range(len(X)):  #цикл

   if i%2==0:

       k+=1

       Z.append(X[i])  #добавляем элемент Z[i], если i - четный

       print(Z)

# проверка на минимум и максимум

       if X[i]>maxc:

           maxc,maxind=X[i],k

       if X[i]<minc:

           minc,minind=X[i],k

   print(minind,maxind,k)

Z[minind]=maxc

Z[maxind]=minc

print(Z)

0,0(0 оценок)
Ответ:
misterbory
misterbory
13.07.2020 18:22

const max=10;

var a:array[1..max,1..max] of integer;

   k1,k2:array[1..max]of byte;  

   n,m,i,j,s1,s2:integer;

begin

repeat

write('Количество строк до ',max,' n=');

readln(n);

until n in [1..max];

repeat

write('Количество столбцов до ',max,' m=');

readln(m);

until m in [1..max];

writeln('Исходная матрица:');

for i:=1 to n do

begin

 for j:=1 to m do

  begin

   a[i,j]:=-15+random(31);

   write(a[i,j]:4);

  end;

 writeln;

end;

s1:=0;

s2:=0;  

for j:=1 to m do

begin

 k1[j]:=0;

 k2[j]:=0;

 for i:=1 to n do

 if abs(a[i,j])>10 then

  begin

   a[i,j]:=10;

   inc(s1);

   inc(k1[j]);

  end

 else

  begin

   a[i,j]:=j;

   inc(s2);

   inc(k2[j]);

  end;

 end;

writeln('Измененная матрица');

for i:=1 to n do

 begin

  for j:=1 to m do

  write(a[i,j]:4);

  writeln;

 end;

writeln('          Количество замен');

writeln('           1 вида  2 вида');

for i:=1 to m do

writeln('Столбец ',i:2,k1[i]:5,k2[i]:5);

writeln('Всего     ',s1:5,s2:5);

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота