В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
STOORIK
STOORIK
21.02.2021 23:31 •  Информатика

Решить по информатике) нужно написать программу на паскале. тема: циклы вот условие) как известно, национальным овощем жителей сказочной страны мурландии является картофель. новое руководство тем, чтобы был сформированы запасы этого ценнейшего продукта на зиму. в этом году был хороший урожай картофеля и n домов со всей мурландии внесли свою лепту в общее хранилище. поставлен план получить не менее k тонн. из каждого дома этой сказочной страны сдали по аi тонн картофеля. можно ли получить k или более тонн картофеля и выполнить план? входные данные: в первой строке входного файла натуральные числа n и k, в последующих n строках содержатся количество тонн картофеля из каждого дома. ограничения: n, k, ai - натуральные числа, не превосходящие 20 000. выходные данные: в единственную строку выходного файла вывести yes в случае ответа "да", no в противном случае.

Показать ответ
Ответ:
arhivnaykr
arhivnaykr
16.08.2020 17:27
Var
tmp,s,i,k,n:integer;
f,w:text;
begin
Assign(f,'input.txt');reset(f);
Assign(w,'output.txt');rewrite(w);
Readln(f,n,k);
for i:= 1 to n do
  begin
  readln(f,tmp);
  s:=s+tmp;
end;
if s >=k then Writeln(w,'Yes')
  else Writeln(w,'No');
  close(f);close(w);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота